Imagine Español

Unity Web Player

You need to install the Unity Web Player plugin in Firefox, Internet Explorer, and Safari to run student sessions with the Imagine Learning web client and to use some features of the Imagine Learning Portal (Imagine Learning Cloud) and Imagine Manager (Imagine Learning v14).

Click on a link below to download the Unity Web Player plugin.

Windows

Unity Web Player version 4.6 (required for v14.3.54.27 and earlier)

Unity Web Player version 5.1 (required for v14.3.54.28 and later)

Mac OS X

Unity Web Player version 4.6 (required for v14.3.54.27 and earlier)

Unity Web Player version 5.1 (required for v14.3.54.28 and later)